Add new attachment

Only authorized users are allowed to upload new attachments.

This page (revision-7) was last changed on 28-May-2007 13:26 by 89.49.139.204  

This page was created on 22-Jun-2006 21:10 by 203.145.154.36

Only authorized users are allowed to rename pages.

Only authorized users are allowed to delete pages.

Difference between version and

At line 5 changed one line
|[Bug criticality]|CriticalBug
|[Bug criticality]|BadBug
At line 7 changed one line
|[Bug status]|NewBug
|[Bug status]|NotReallyBug
At line 17 added one line
{{{
At line 34 changed one line
}}}
At line 38 added 56 lines
----
Downgraded in priority, as there is a workaround. This sort of sounds like something to do with the browser. Does this occur consistently with one type of browser?
-- JanneJalkanen
Bug reporter doesn't answer your question, (it's 6 month since you asked), bug gets closed.
-- HarryMetske
----
I have the same problem with JSPWiki-2.4.102 on JBoss-4.0.5.GA every time when using IE6. Firefox works ok, but it's no workaround for me since the default enterprise browser is IE6. It's interesting that the fckeditor upload works always fine.
{{{
14:49:51,700 ERROR [[AttachmentServlet]] Servlet.service() for servlet AttachmentServlet threw exception
java.io.IOException: Invalid Form Data, no boundary encountered.
at http.utils.multipartrequest.MultipartRequest.parse(MultipartRequest.java:897)
at http.utils.multipartrequest.MultipartRequest.initParser(MultipartRequest.java:631)
at http.utils.multipartrequest.MultipartRequest.<init>(MultipartRequest.java:406)
at com.ecyrd.jspwiki.attachment.AttachmentServlet.upload(AttachmentServlet.java:493)
at com.ecyrd.jspwiki.attachment.AttachmentServlet.doPost(AttachmentServlet.java:412)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at com.ecyrd.jspwiki.dav.WebdavServlet.service(WebdavServlet.java:152)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
at com.ecyrd.jspwiki.ui.WikiServletFilter.doFilter(WikiServletFilter.java:100)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:175)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:432)
at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:74)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
at org.jboss.web.tomcat.tc5.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:156)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
at java.lang.Thread.run(Thread.java:534)
}}}
-- DimitarMarinov
Ok, i found the reason for the exceptions now. It's not really JSPWiki bug. The problem appears only when using the NTLM filter for authentication. Once using NTLM in some context the M$ browser IE expects NTLM through the rest of the whole session for this context. If it's not there IE sends ContentLength:0 and the upload fails. So, the solution is just to turn on the NTLM filter for all pages and everything works like a charm.
-- DimitarMarinov
Version Date Modified Size Author Changes ... Change note
7 28-May-2007 13:26 5.701 kB 89.49.139.204 to previous
6 28-May-2007 13:25 5.701 kB 89.49.139.204 to previous | to last
5 09-May-2007 16:25 5.239 kB 193.18.239.4 to previous | to last
4 09-May-2007 16:23 5.234 kB DimitarMarinov to previous | to last
3 02-Mar-2007 00:44 2.075 kB HarryMetske to previous | to last bug closed
2 13-Aug-2006 22:55 1.96 kB Janne Jalkanen to previous | to last
1 22-Jun-2006 21:10 1.755 kB 203.145.154.36 to last
« This page (revision-7) was last changed on 28-May-2007 13:26 by 89.49.139.204