|Title|Bad code signer error for WeblogCategoryPlugin under 2.3.95
|Date|07-Apr-2006 17:15:24 EEST
|Version|2.3.95
|Submitter|Mike Morris
|[Bug criticality]|MediumBug
|Browser version|Firefox 1.5
|[Bug status]|ClosedBug
|[PageProvider] used|VersioningFileProvider
|Servlet Container|Tomcat 5.5
|Operating System|Linux
|URL|
|Java version|1.5.0.1

WeblogCategoryPlugin fails, with the following message displayed on the containing page:

Plugin insertion failed: class "com.ecyrd.jspwiki.plugin.WeblogCategoryPlugin"'s signer information does not match signer information of other classes in the same package


----

Mike --

The problem is that you are using a 3rd-party class __and__ it uses a JSPWiki package name (com.ecyrd.jspwiki...). Because we sign the JSPWiki jar, the JRE will reject any other classes that aren't signed. You have two options:

* Put the class in a different package (e.g., com.mikemorris.jspwiki)
* Add the WeblogCategoryPlugin class into a local copy of the JSPWiki source tree, and re-build the JSPWiki jar. This will cause the class to be signed.

See Janne's [blog entry|http://blog.jspwiki.org/wiki/Main_blogentry_260106_1] about this. See also [this thread on the mailing list|http://www.ecyrd.com/pipermail/jspwiki-users/2005-November/000807.html].

Also, if you know who developed the [WeblogCategoryPlugin], you might want to ask them to provide a different package name for it.

--Andrew Jaquith, 12-Apr-2006