TitleConfiguration Error for JSPWiki-container ON Weblogic 9.2
Date22-Feb-2007 03:41:33 EET
Version2.4.9
Submitterjava4yogi
Bug criticalityFatalBug
Browser versionI.E.6
Bug statusClosedBug
PageProvider used
Servlet ContainerWeblogic
Operating SystemWINDOWS XP
URL/JSPWiki
Java version1.5

I am trying to run the JSP Wiki app in Weblogic and am getting a configuration error when I try to access the main page.

The error description is given below.

java.lang.IllegalArgumentException: No Configuration was registered that can handle the configuration named JSPWiki-container
	at com.bea.common.security.jdkutils.JAASConfiguration.getAppConfigurationEntry(JAASConfiguration.java:54)
	at javax.security.auth.login.LoginContext.init(LoginContext.java:243)
	at javax.security.auth.login.LoginContext.(LoginContext.java:367)
	at javax.security.auth.login.LoginContext.(LoginContext.java:444)
	at com.ecyrd.jspwiki.WikiSession.getLoginContext(WikiSession.java:246)
	at com.ecyrd.jspwiki.auth.AuthenticationManager$2.run(AuthenticationManager.java:401)
	at java.security.AccessController.doPrivileged(Native Method)
	at com.ecyrd.jspwiki.auth.AuthenticationManager.doLogin(AuthenticationManager.java:396)
	at com.ecyrd.jspwiki.auth.AuthenticationManager.login(AuthenticationManager.java:246)
	at com.ecyrd.jspwiki.WikiContext.(WikiContext.java:256)
	at com.ecyrd.jspwiki.WikiEngine.createContext(WikiEngine.java:1922)
	at jsp_servlet.__wiki._jspService(__wiki.java:106)
	at weblogic.servlet.jsp.JspBase.service(JspBase.java:34)
	at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:225)
	at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:127)
	at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:283)
	at weblogic.servlet.internal.ServletStubImpl.onAddToMapException(ServletStubImpl.java:391)
	at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:309)
	at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:26)
	at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:42)
	at com.ecyrd.jspwiki.ui.WikiServletFilter.doFilter(WikiServletFilter.java:99)
	at com.ecyrd.jspwiki.ui.WikiJSPFilter.doFilter(WikiJSPFilter.java:71)
	at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:42)
	at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3212)
	at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
	at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
	at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:1983)
	at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:1890)
	at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1344)
	at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
	at weblogic.work.ExecuteThread.run(ExecuteThread.java:181)


I was able to get the lookup resolved for the JAAS file in Weblogic. Sent the changes needed in the users mailing list for the same.

However, now when the JAAS file is loaded, I am getting another error.

It is not able to parse the jaas config file and gives an error.

Are there any specific changes needed to get JAAS working on Weblogic or anyway JSPWiki can work without JAAS mechanism.

This is the exact error which I get

<Feb 23, 2007 5:12:15 PM PST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STANDBY> <Feb 23, 2007 5:12:15 PM PST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING> java.security.policy: error parsing file:/C:/bea/user_projects/domains/pas_dev_domain/config/jaas.config: line 1: expected ;, found JSPWiki
This is the code in the jaas.config file
JSPWiki-container { com.ecyrd.jspwiki.auth.login.WebContainerLoginModule required; com.ecyrd.jspwiki.auth.login.WebContainerLoginModule SUFFICIENT; com.ecyrd.jspwiki.auth.login.CookieAssertionLoginModule SUFFICIENT; com.ecyrd.jspwiki.auth.login.AnonymousLoginModule SUFFICIENT; };
Appreciate your advice in this regard. Thank You.

--java4yogi, 24-Feb-2007

Verify if you follow correctly the configuration steps for WebLogic. Here

--giorgio, 2-Mar-2007


Waiting for bug reporter

--HarryMetske


Closing bug, no response from bug reporter after a month....

--HarryMetske

Add new attachment

Only authorized users are allowed to upload new attachments.
« This page (revision-7) was last changed on 03-Apr-2007 21:45 by HarryMetske