TitleExceeded stated content-length exception under Weblogic
Date12-Jul-2006 23:20:09 EEST
Version2.4.18
Submitter199.43.48.87
Bug criticalityBadBug
Browser versionIE6
Bug statusClosedBug
PageProvider usedVersioningFileProvider
Servlet ContainerWebLogic 910
Operating SystemSolaris
URLMain
Java version1.5.0

I get the following ProtocolException when running JSPWiki under WebLogic 910, the exception is reported as soon as I access a Wiki page.

####<Jul 12, 2006 6:34:52 PM GMT> <Error> <HTTP> <mhs-apps150-s> <websiteServer> <[ACTIVE] ExecuteThread: '1' for 
queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1152729292014> <BEA-101019>
<[weblogic.servlet.internal.WebAppServletContext@1d29c1 -
name: 'wiki.war', context-path: '/wiki'] Servlet failed with IOException
java.net.ProtocolException: Exceeded stated content-length of: '0' bytes
        at weblogic.servlet.internal.ServletOutputStreamImpl.checkCL(ServletOutputStreamImpl.java:219)
        at weblogic.servlet.internal.ServletOutputStreamImpl.write(ServletOutputStreamImpl.java:166)
        at java.io.OutputStream.write(OutputStream.java:58)
        at com.ecyrd.jspwiki.ui.WikiServletFilter.doFilter(WikiServletFilter.java:120)
        at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:42)
        at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3151)
        at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
        at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
        at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:1973)
        at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:1880)
        at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1310)
        at weblogic.work.ExecuteThread.execute(ExecuteThread.java:207)
        at weblogic.work.ExecuteThread.run(ExecuteThread.java:179)


Hmmm... I have no idea at the moment where this might be coming from. Could you debug it a bit further? Anyone with access to WebLogic?

-- JanneJalkanen


I get the exact same thing in Weblogic when I upgraded to 2.4.40.

I only got it when I turned security on. I am just trying to figure that security stuff out.

--DaveLeo, 06-Sep-2006


This should be fixed in 2.4.52. Could someone confirm?

-- JanneJalkanen


Since there is no confirmation, even after 6 months , bug closed.

--HarryMetske

Add new attachment

Only authorized users are allowed to upload new attachments.
« This page (revision-7) was last changed on 02-Mar-2007 23:35 by HarryMetske