|Title|Inline images as InterWiki links don't inline
|Date|16-Apr-2005 20:45:48 EEST
|Version|2.0.45
|Submitter|JanneJalkanen
|[Bug criticality]|MediumBug
|Browser version|
|[Bug status]|ClosedBug
|[PageProvider] used|VersioningFileProvider
|Servlet Container|
|Operating System|Solaris 8
|URL|
|Java version|


Okay, so since I have some users of.... errrr... limited!  technical capacity, I
thought I would be nice and define an InterWiki tag for inlining images like this:

{{jspwiki.interWikiRef.image = http://www.cocosoft.co.za/wikipix/%s}}

where %s is the name of a picture (gif/jpg/png) file uploaded to the right place (actually on a separate server, since I have a Solaris box doing Tomcat with Apache on Linux via jk2 doing the Front-of-House).

Very clever, I thought.  Only it doesn't work :-(...

Seems that as soon as the InterWiki matching happens, no further parsing/reparsing occurs to look for image inlining.  Of course just linking to the image in the normal way still works, so its really not very serious -- more a kind of nice-to-have.

--MikeMorris

Just to bring it up again (dormant since from April 2005): It seems that fixing this problem should be relatively easy and would help us a great deal. We have a similar problem with images, images being handled by a separate upload service and serviced through a servlet. Please do fix this problem, I can not see why cascading the interwiki and the inline image parser could create a problem...

-- Gregor Hagedorn - Nov. 2005

I increased the level of this bug, so that I would remember it better :).  No reason, things just fall through cracks sometimes.  It's quite a lot more probable that a feature goes in if someone develops a patch for it.

-- JanneJalkanen

Oops, forgot to mark this fixed.  Available in 2.3.49 onwards...