|Title|Lock Not Working
|Date|04-Sep-2006 22:41:13 EEST
|Version|2.4.38
|Submitter|T. Steichen
|[Bug criticality]|BadBug
|Browser version|Firefox 1.5
|[Bug status]|ClosedBug
|[PageProvider] used|JDBCPageProvider
|Servlet Container|Tomcat 5.5.17
|Operating System|Windows XP
|URL|Any
|Java version|1.5

Lock doesn't seem to be working.  When I lock a page or two using one browser instance, and check the lock, it shows that the acquisition time and expiry time are the same.  Thus the lock lasts until the LockReaper goes around the first time.  I tried changing the value of jspwiki.lockExpiryTime from 60 to 6000, but it changed nothing.



----

I see the very same problem (JSPWiki 2.4.40-beta, Tomcat 5.5.17, z/OS 1.6)

I would consider this a Critical Bug and not a bad Bug

--Harry Metske, 05-Sep-2006

----

Fixed in 2.4.46.  It was a cut-n-paste-o, introduced in 2.4.28.  Stupid me...


----

I also noticed that on this wiki (www.jspwiki.org) there are currently no locks, while usually there are at least 10 locks .

--Harry Metske, 05-Sep-2006


----

Oh, that's very fast, let me get 2.4.46.....
\\thanks !

--Harry Metske, 05-Sep-2006


----

hmmmm, where is 2.4.46, on the downloads page I see that 2.4.45 is "the latest cutting edge"... ?

--Harry Metske, 05-Sep-2006

----

Check again?  It takes sometimes a while for the page to be updated.

-- JanneJalkanen


----

Yep, I have now installed 2.4.46-cvs, and the lock problem is solved !
\\Great, good support !
\\(I'm used to working with expensive commercial software (I won't mention vendor names), but with these guys it usually takes weeks/months to get a problem solved !)

regards,
Harry 

--Harry Metske, 05-Sep-2006

----

Well, with us it always depends on whether we have enough free time or not... So big vendors may be slow, but at least they're reliable ;-)

-- JanneJalkanen