|Title|Login error when using CMS
|Date|08-Jul-2006 00:49:54 EEST
|Version|2.4.18
|Submitter|Nascif Abousalh-Neto
|[Bug criticality]|BadBug
|Browser version|Firefox
|[Bug status]|ClosedBug
|[PageProvider] used|Versioned
|Servlet Container|Tomcat 5.5.17
|Operating System|WindowsXP
|URL|
|Java version|1.5.0

''Similar to an entry in [Stupid Questions] by Bruce E Hayward.\\
I have exactly the same problem in my environment.''

I configured my wiki to use CMS, based on the Tomcat memory realm. 
I can start the wiki and view pages. When I try to login (with a user name and password that I know are valid in the Tomcat configuration) I get the following error:

{{{
HTTP Status 404 - /MyWiki/j_security_check
type Status report
message /MyWiki/j_security_check
description The requested resource (/MyWiki/j_security_check) is not available.
}}}

From what I read about j_security_check this is probably due to a configuration error, but I have to idea (nor found the documentation) on how to solve it...

Please [AnswerMe].

----

Opened this one, but I have no immediate answer.  Downgraded also since it seems to be a config issue.

-- JanneJalkanen, 24-Sep-2006


----

This indeed sounds like a config issue, to enable us to debug it further, could you attach the following files to this page:

# tomcat's ./conf/server.xml
# JSPWiki's ./WEB-INF/web.xml


--HarryMetske, 04-Mar-2007

----
I don't expect an answer anymore, closing the bug, feel free to re-open if you still find the bug and have the requested diagnostic material.

--HarryMetske