TitleTemplate JSP Not Found on v2.4.30
Date06-Aug-2006 00:03:47 EEST
Versionv2.4.30
SubmitterDirk Frederickx
Bug criticalityBadBug
Browser versionsafari
Bug statusClosedBug
PageProvider used
Servlet Containertomcat
Operating Systemosx
URL
Java version

Something seems to be wrong with v2.4.30 when rendering with another template.

Apparently JSPWiki keeps fetching its JSPs from the templates/default directory, after having set a different template-directory.

Some bits and pieces get loaded from the real template-directory (see commmonheader.jsp which refers to several 'templatefiles') causing the rendered screens to break.

--DF


So you mean that even if they exist in the new template directory, they still get fetched from the default template directory? JSPWiki should be fetching files from the default template only if they don't exist in the specified template...

Could you provide an example?

-- JanneJalkanen


Hi Janne,

The problem seems to be related with caching. (allthough i am not 100% sure -- i get several strange behaviours...)

I actually renamed the templates/brushed to templates/default, and still the pages were rendered on the old /templates/default jsp's. After that, I flushed the work and temp directories of TOMCAT, restarted everything, and all was ok.

Normally , when changing to another template, I just change the jspwiki.propoerties, and restart the web-app via the tomcat /manager console. This approach is not working anymore.

Some more info: it also seems that <wiki:TemplateDir/> is broken; but <wiki:Link format='url' templatefile='... seems to be ok.

--DF

Closed in v2.4.32. Tx !

Add new attachment

Only authorized users are allowed to upload new attachments.
« This page (revision-7) was last changed on 09-Aug-2006 21:45 by 84.192.32.68