TitleUsing Bug Submission Form Destroys Some Characters in Text
Date15-Nov-2005 15:31:37 EET
Version2.2.32 cvs
SubmitterGregorHagedorn
Bug criticalityJSPWiki:LightBug
Browser version
Bug statusClosedBug
PageProvider used
Servlet Container
Operating System
URL
Java version

On the JSPWiki site, while submitting the BugStrangePageNameLogic, use of the dash caused a locally corrupt text.

The first of both words uses dash, the second hyphen. The dash seems to be mistreated when writing in the form plugin. However, it works ok when using the normal wiki editor!

phobous -phobous
tetra tetra-

Gregor Hagedorn, 2005-11-15


My guess is that you're using Windows - emdash, endash and backtick are known problem characters with Windows. E.g. on Mac, they seem to work fine.

-- JanneJalkanen

Yes, Windows, but I am using the unicode dash, not the special Windows ANSI character with the same glyph.

The major point is however, that with the normal Wiki page editor these characters work fine, whereas they seem to break when using the Wiki form plugin! Thus the problem is fixable and not dependent on the client used. -- Gregor

See test in Bug Using Bug Submission Form Destroys Some Unicode Characters In Text

The bug report should probably be renamed Destroys ALL Unicode...

-- Gregor

Should be fixed in 2.3.50.

-- JanneJalkanen

Add new attachment

Only authorized users are allowed to upload new attachments.
« This page (revision-6) was last changed on 07-Dec-2005 08:49 by Janne Jalkanen