Titleworks in windows. when deployed in sunsolaris and access gets error
Date12-Jul-2006 00:38:44 EEST
Versionjspwiki-2.2.33-bin
Submitter166.68.134.175
Bug criticalityMediumBug
Browser versionIE 6
Bug statusNotABug
PageProvider used
Servlet ContainerTomcat 4.1.3
Operating SystemSunsolaris
URLhttp://nike.basit.com:8080/dtiwiki/Wiki.jsp
Java versionjdk1.2.2

Hi,

I have installed JSPWiki in windows and deployed war file (extracted all contents) in Tomcat 4.1.3 and it works fine. When i installed JSPWiki in SunSolaris and deployed extracted war contents under webapps directory.

When i try to access, am getting following exception

exception javax.servlet.ServletException: com/ecyrd/jspwiki/tags/AttachmentsIteratorInfo (Unsupported major.minor version 48.0)

java.lang.UnsupportedClassVersionError: com/ecyrd/jspwiki/tags/AttachmentsIteratorInfo (Unsupported major.minor version 48.0)

I am not sure what is the problem.

Environment details: OS - Sun Solaris Using CATALINA_BASE: /opt/cafe/tomcat/jakarta-tomcat-4.1.31 Using CATALINA_HOME: /opt/cafe/tomcat/jakarta-tomcat-4.1.31 Using JAVA_HOME: /opt/openfusion2/jdk1.2.2 Thanks in advance - Jack


UnsupportedClassVersionError means the VM does not recognize the class file format (which means, most of the time, that the JDK you use to run the software is older than the JDK that compiled the software).

Indeed, see the System Requirements in JspWikiDownload: JspWiki v2.2 and above require JDK1.4 or above. You probably have one of those on the Windows machine...


Closing; JSPWiki requires 1.4 or above.

Add new attachment

Only authorized users are allowed to upload new attachments.
« This page (revision-5) was last changed on 14-Jul-2006 12:21 by Janne Jalkanen