I'm getting "resource not available" errors and the log contains

2004-09-28 16:26:41 No jspwiki.propertyfile defined for this context, 
using default from /WEB-INF/jspwiki.properties

I'm guessing this just needs a simple config tweak to point something at the right jspwiki.properties, but I can't figure out what or where

--NeilYoungman

A: Don't worry, this is fine. You can set a servlet property to point at a jspwiki.properties file, so you can use the same WAR-file but different configurations. See MultipleWikis for more information. JSPWiki is just informing you that it is using the default configuration, which is fine for 90% of the cases.

Your problem is likely to be something else.

--JanneJalkanen

OK. I Fixed this by creating a context entry in a new file /var/lib/tomcat4/webapps/wikifast.xml, which was an edited copy of /var/lib/tomcat4/webapps/jspwiki.xml

#diff jspwiki.xml wikifast.xml 
1c1
< <Context path="/JSPWiki" docBase="/usr/share/java/webapps/JSPWiki">
---
> <Context path="/WikiFast" docBase="/usr/share/java/webapps/WikiFast">

It seems to be working, but some exceptions appear in the log

2004-09-29 11:25:51 StandardManager[/JSPWiki] IOException while loading persisted sessions: java.io.WriteAbortedException: writing aborted;
java.io.NotSerializableException: org.apache.jasper.runtime.PageContextImpl
--NeilYoungman

I too am having this error of "No jspwiki.propertyfile defined for this context, using default from /WEB-INF/jspwiki.properties" my conf/Catalina/localhost/JSPWiki.xml file is:

<Context path="/Meghna" docBase="JSPWiki.war" debug="0">
<Parameter name="jspwiki.propertyfile" value="/var/www/tomcat5/conf/Meghna.properties" override="false" />
</Context>

<Context path="/Yong" docBase="JSPWiki.war" debug="0">
<Parameter name="jspwiki.propertyfile" value="/var/www/tomcat5/conf/Yong.properties" override="false" />
</Context>

<Context path="/Dawsey" docBase="JSPWiki.war" debug="0">
<Parameter name="jspwiki.propertyfile" value="/var/www/tomcat5/conf/Dawsey.properties" override="false" />
</Context>

and the error in the tomcat5 logs is:

2004-12-13 23:06:30 StandardContext[/Meghna]Application 25103764 requests WikiEngine.
2004-12-13 23:06:30 StandardContext[/Meghna] Assigning new log to 25103764
2004-12-13 23:06:30 StandardContext[/Meghna]Reading properties from /var/www/tomcat5/conf/Meghna.properties instead of default.
2004-12-13 23:12:11 StandardHost[localhost]: Error deploying application at context path null
org.xml.sax.SAXParseException: XML document structures must start and end within the same entity.
        at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
        at org.apache.commons.digester.Digester.parse(Digester.java:1567)
        at org.apache.catalina.core.StandardHostDeployer.install(StandardHostDeployer.java:488)
        at org.apache.catalina.core.StandardHost.install(StandardHost.java:863)
        at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:483)
...
        at java.lang.Thread.run(Thread.java:534)

2004-12-13 23:12:45 StandardWrapperValve[jsp]: Servlet.service() for servlet jsp threw exception
java.lang.NullPointerException
        at org.apache.jsp.Wiki_jsp._jspDestroy(Wiki_jsp.java:39)
        at org.apache.jasper.runtime.HttpJspBase.destroy(HttpJspBase.java:85)
        at org.apache.jasper.servlet.JspServletWrapper.destroy(JspServletWrapper.java:378)
        at org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:133)
        at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:307)
        at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:292)
        at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:236)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
...
        at java.lang.Thread.run(Thread.java:534)
To me, it appears that my /Meghna wiki is working correctly (and actually is) but the following two, /Yong and /Dawsey, are not operating. If one has any ideas to a solution I would be very greatful.

I am using apache tomcat/5.0.28 and JSPWiki 2.0.52 (which btw is awesome)

--NathanLester

THIS IS NOT AN ERROR! I REPEAT, THIS IS NOT AN ERROR! It's just an informative message from JSPWiki that it is using a default version of the jspwiki.properties.

Please see MultipleWikis to see how the jspwiki.properties location can be set to allow multiple wikis using the same set of libraries.

--JanneJalkanen

My problem occurs from the main page. From here I have links to other wiki projects (Meghna, Dawsey, Yong) and I updated the jspwiki.properties file and placed Meghna.properties Dawsey.properties and Yong.properties in the conf/ directory and created the conf/Catalina/localhost/JSPWiki.xml file as listed above. From the main page I have links to the Meghna:Home Dawsey:Home and Yong:Home projects. Cliking on the Meghna:Home link works but the other two don't. Clicking on them gives me a generic HTTP 500 error 'the server encountered an internal error() that prevented it from fulfilling this request'. Could it be that my JSPWiki.xml file is incorrect? I am not sure how it works. Again, I thank you for your help.

-- NathanLester

I haven't tried this, but I believe you need one xml file per context, e.g. create Meghna.xml, Dawsey.xml and Yong.xml and make each file contain only its context description. XML files usually need to have exactly one root element, yours has three of them (as said: have not tried this). (n.b. I've edited the xml snippet to contain some linebreaks and shortened stacktraces)

-- OlafKock

I tried to make Wiki 2.4.56 work in RAD 6 but can't get it to work. I have JSPWiki v2.2.33 installed in the same workspace and it works fine.
Everytime I try to run the new wiki I get this error:

[26-09-06 14:09:48:369 CEST] 00000034 WebApp        A   SRVE0180I: [JSPWiki] [/JSPWiki1] [Servlet.LOG]: Application 1823166371 requests WikiEngine.
[26-09-06 14:09:48:369 CEST] 00000034 WebApp        A   SRVE0180I: [JSPWiki] [/JSPWiki1] [Servlet.LOG]:  Assigning new log to 1823166371
[26-09-06 14:09:48:400 CEST] 00000034 WebApp        A   SRVE0180I: [JSPWiki] [/JSPWiki1] [Servlet.LOG]: No jspwiki.propertyfile defined for this context, using default from /WEB-INF/jspwiki.properties
[26-09-06 14:09:48:432 CEST] 00000034 ServletWrappe E   SRVE0100E: Did not realize  init() exception thrown by servlet /Wiki.jsp: java.lang.VerifyError: (class: com/ecyrd/jspwiki/plugin/PluginManager, method: parsePluginLine signature: (Lcom/ecyrd/jspwiki/WikiContext;Ljava/lang/String;)Lorg/jdom/Content;) Wrong return type in method
	at com.ecyrd.jspwiki.WikiEngine.initialize(WikiEngine.java:537)
	at com.ecyrd.jspwiki.WikiEngine.<init>(WikiEngine.java:431)
	at com.ecyrd.jspwiki.WikiEngine.getInstance(WikiEngine.java:330)
	at com.ecyrd.jspwiki.WikiEngine.getInstance(WikiEngine.java:282)
	at com.ibm._jsp._Wiki.jspInit(_Wiki.java:41)
	at com.ibm.ws.jsp.runtime.HttpJspBase.init(HttpJspBase.java:70)
	at com.ibm.ws.webcontainer.servlet.ServletWrapper.init(ServletWrapper.java:262)
	at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:444)
	at com.ibm.wsspi.webcontainer.servlet.GenericServletWrapper.handleRequest(GenericServletWrapper.java:117)
	at com.ibm.ws.jsp.webcontainerext.JSPExtensionServletWrapper.handleRequest(JSPExtensionServletWrapper.java:171)
	at com.ibm.ws.jsp.webcontainerext.JSPExtensionProcessor.handleRequest(JSPExtensionProcessor.java:230)
	at com.ibm.ws.webcontainer.extension.DefaultExtensionProcessor.handleRequest(DefaultExtensionProcessor.java:394)
	at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:2837)
	at com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:220)
	at com.ibm.ws.webcontainer.VirtualHost.handleRequest(VirtualHost.java:204)
	at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:1681)
	at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:77)
	at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:421)
	at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewInformation(HttpInboundLink.java:367)
	at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.ready(HttpInboundLink.java:276)
	at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.sendToDiscriminaters(NewConnectionInitialReadCallback.java:201)
	at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.complete(NewConnectionInitialReadCallback.java:103)
	at com.ibm.ws.tcp.channel.impl.WorkQueueManager.requestComplete(WorkQueueManager.java:548)
	at com.ibm.ws.tcp.channel.impl.WorkQueueManager.attemptIO(WorkQueueManager.java:601)
	at com.ibm.ws.tcp.channel.impl.WorkQueueManager.workerRun(WorkQueueManager.java:934)
	at com.ibm.ws.tcp.channel.impl.WorkQueueManager$Worker.run(WorkQueueManager.java:1021)
	at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1332)
I imported the war file into RAD 6. Can anyone help me?

--Manie

Hi Manie,

it's a Problem of the Server-Configuration. RAD isn't deploying your Project into the Directory of Tomcat. Double-click into the file /Servers/Tomcat v5.0 Server.server and take care that inside of Server the checkbox "Run modules directly from..." is unchecked. I hope this will resolving your problem

Jens

Add new attachment

Only authorized users are allowed to upload new attachments.
« This page (revision-24) was last changed on 07-Jun-2007 08:15 by MurrayAltheim