If you are having problems with Tomcat 5.x and JSPWiki with UTF-8, please note the following!

You have to edit server.xml of Tomcat (is in the conf-directory of Tomcat). Please add to 

{{{<Connector port="8080"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" redirectPort="8443" acceptCount="100"
               debug="0" connectionTimeout="20000" 
               disableUploadTimeout="true"/>}}}

the term '{{{URIEncoding="UTF-8"}}}'.

It should look like that:

{{{<Connector port="8080"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" redirectPort="8443" acceptCount="100"
               debug="0" connectionTimeout="20000" 
               disableUploadTimeout="true" 
               URIEncoding="UTF-8"/>}}}

Remember that if you use mod_jk, you should define the {{URIEncoding}} for the AJK Connector, too.

------

WARNING: Our Wikis running on 2.2.33 with jspwiki.properties set to UTF-8 did not display pages anymore that contained Umlaute after setting this. I had to disable the URIEncoding again.

--[Christoph Sauer] 2-Sep.2006
------
Using jk connector and Apache needs extra settings.

This is my successful configuration.
(Suse10.1 / Tomcat5.0 and 5.5 / JSPWiki v2.4.87)

/etc/tomcat5/base/server.xml (based on "server-minimal.xml" by SuSE)
{{{
<Server port=8005 shutdown="SHUTDOWN">
.........
  <service name="Catalina">
    <connector port="8080" />
.........
    <connector protocol="AJP/1.3" uriencoding="UTF-8" port="8009" />
.........
  </service>
</server>
}}}
--Kei Watanabe 10-jan.2007 / 21 Dec.2007


----

via jk, Set also useBodyEncodingForURI="true" see: [ApacheTomcatConnection]\\
In UTF-8 the Title (with accent) is not encoded well and the [[LinkTag] (with the accent) doesn't match the page

--elannaud, 18-sept.-2008 16:11